symfony/web-link

Manages links between resources

PHP

1,416

248 commits

updated Oct 9, 2026

See the code

README

WebLink Component

The WebLink component manages links between resources. It is particularly useful to advise clients to preload and prefetch documents through HTTP and HTTP/2 pushes.

This component implements the HTML5's Links, Preload and Resource Hints W3C's specifications. It can also be used with extensions defined in the HTML5 link type extensions wiki.

It also implements Web Linking (RFC 8288), the two link set document formats defined by Linkset (RFC 9264) and the Link-Template HTTP header field (RFC 9652).

Getting Started

composer require symfony/web-link
use Symfony\Component\WebLink\GenericLinkProvider;
use Symfony\Component\WebLink\HttpHeaderSerializer;
use Symfony\Component\WebLink\Link;

$linkProvider = (new GenericLinkProvider())
    ->withLink(new Link('preload', '/bootstrap.min.css'));

header('Link: '.(new HttpHeaderSerializer())->serialize($linkProvider->getLinks()));

echo 'Hello';

This package is looking for a backer.

Help Symfony by sponsoring its development!

Resources

component
dns-prefetch
http
http2
link
linkset
performance
php
prefetch
preload
prerender
psr13
push
symfony
symfony-component

symfony/web-link

Manages links between resources

PHP

1,416

248 commits

updated Oct 9, 2026

See the code

README

WebLink Component

The WebLink component manages links between resources. It is particularly useful to advise clients to preload and prefetch documents through HTTP and HTTP/2 pushes.

This component implements the HTML5's Links, Preload and Resource Hints W3C's specifications. It can also be used with extensions defined in the HTML5 link type extensions wiki.

It also implements Web Linking (RFC 8288), the two link set document formats defined by Linkset (RFC 9264) and the Link-Template HTTP header field (RFC 9652).

Getting Started

composer require symfony/web-link
use Symfony\Component\WebLink\GenericLinkProvider;
use Symfony\Component\WebLink\HttpHeaderSerializer;
use Symfony\Component\WebLink\Link;

$linkProvider = (new GenericLinkProvider())
    ->withLink(new Link('preload', '/bootstrap.min.css'));

header('Link: '.(new HttpHeaderSerializer())->serialize($linkProvider->getLinks()));

echo 'Hello';

This package is looking for a backer.

Help Symfony by sponsoring its development!

Resources

component
dns-prefetch
http
http2
link
linkset
performance
php
prefetch
preload
prerender
psr13
push
symfony
symfony-component

Project health

Overall

3.8/10

Maintained

5/10

Code review

0/10
OpenSSF Scorecard

Significant stargazers

Javier Eguiluz

1,668 followers · starred Nov 2017

Derick Rethans

1,840 followers · starred Feb 2021

Mark Young

8 followers · starred Nov 2018

Bruno Baguette

4 followers · starred Apr 2025