halfrost/Halfrost-Field

✍🏻 Source Code Deep Dives, System Design & Engineering Blogs | Halfrost-Field 冰霜之地:源码解析、系统设计与工程实践笔记

Go

13,245

1,070 commits

updated Sep 30, 2026

See the code

README

Halfrost-Field

English  |  中文

visitor badge

GitHub

⭐️ Why I Created This Repository

People often say that reading the source code of open-source frameworks can significantly improve one’s skills, so I have also tried reading open-source framework source code and analyzing and understanding it in detail. Here I record my thoughts and insights from reading open-source framework source code, hoping they will be helpful to other developers. I will keep updating the articles in this repository; if you’d like to follow along, please give it a star.

📖 Table of Contents

🔥 LLM


🐳 Go


🍉 Machine Learning


🚀 JavaScript


📝 Protocol

ProjectVersionArticle
HTTP1.1Overview of HTTP Basics
HTTP2[RFC 7540] Hypertext Transfer Protocol Version 2 (HTTP/2)
Unveiling HTTP/2: How HTTP/2 Establishes Connections
HTTP Frames and Stream Multiplexing in HTTP/2
Frame Definitions in HTTP/2
HTTP Semantics in HTTP/2
Things to Note in HTTP/2
Common Questions in HTTP/2
[RFC 7541] HPACK: Header Compression for HTTP/2
A Detailed Look at the HTTP/2 Header Compression Algorithm — HPACK
Practical Examples of HTTP/2 HPACK
[RFC 7301] TLS Application-Layer Protocol Negotiation Extension
WebSocketVersion 13WebSocket for Full-Duplex Communication
Protocol-buffersproto3Protobuf: An Efficient Data Compression and Encoding Format
Protobuf: An Efficient Data Serialization/Deserialization Format
FlatBuffers1.9.0FlatBuffers Explained: Schema
FlatBuffers Explained: Encode
FlatBuffers Explained: FlexBuffers
TCPOverview of TCP/IP Basics
Advance_TCP
TLSCryptography
Overview of Cryptography
A Tour of Symmetric Encryption Algorithms
A Tour of Public-Key Cryptography Algorithms
What Is a Message “Fingerprint”?
What Is a Message Authentication Code?
Ubiquitous Digital Signatures
Everywhere You Look: Public-Key Certificates
The Essence of Secrets: Keys
The Root of Unpredictability—Random Numbers
TLSTLS 1.3
How to Deploy TLS 1.3?
[RFC 6520] TLS & DTLS Heartbeat Extension
[RFC 8446] The Transport Layer Security (TLS) Protocol Version 1.3
TLS 1.3 Introduction
TLS 1.3 Handshake Protocol
TLS 1.3 Record Protocol
TLS 1.3 Alert Protocol
TLS 1.3 Cryptographic Computations
TLS 1.3 0-RTT and Anti-Replay
TLS 1.3 Compliance Requirements
TLS 1.3 Implementation Notes
TLS 1.3 Backward Compatibility
TLS 1.3 Overview of Security Properties
HTTPSTLS 1.2/TLS 1.3HTTPS: Revisiting the Basics (1) — Introduction
HTTPS: Revisiting the Basics (2) — The TLS Record Layer Protocol
HTTPS: Revisiting the Basics (3) — An Intuitive Look at the TLS Handshake Process (Part 1)
HTTPS: Revisiting the Basics (4) — An Intuitive Look at the TLS Handshake Process (Part 2)
HTTPS: Revisiting the Basics (5) — Key Calculation in TLS
HTTPS: Revisiting the Basics (6) — Extensions in TLS
QUICv44How to Deploy QUIC?
                                                            

❄️ As Time Goes By

❗️ Errata

  • If you find any issues in the article, feel free to submit a PR or issue. Expert feedback and guidance are very welcome 🙏🙏🙏

♥️ Thanks

Thanks for the Star!

Star History Chart

🌈 WeChat Official Account

©️ Reposting

Creative Commons License
This work by halfrost is licensed under a Creative Commons Attribution 4.0 International License.

algorithms
blog
cryptography
go
golang
http2
inference-engine
ios
javascript
llm
machine-learning
network-protocols
objective-c
protobuf
source-code-analysis
swift
system-design
technical-writing
tls
vllm

halfrost/Halfrost-Field

✍🏻 Source Code Deep Dives, System Design & Engineering Blogs | Halfrost-Field 冰霜之地:源码解析、系统设计与工程实践笔记

Go

13,245

1,070 commits

updated Sep 30, 2026

See the code

README

Halfrost-Field

English  |  中文

visitor badge

GitHub

⭐️ Why I Created This Repository

People often say that reading the source code of open-source frameworks can significantly improve one’s skills, so I have also tried reading open-source framework source code and analyzing and understanding it in detail. Here I record my thoughts and insights from reading open-source framework source code, hoping they will be helpful to other developers. I will keep updating the articles in this repository; if you’d like to follow along, please give it a star.

📖 Table of Contents

🔥 LLM


🐳 Go


🍉 Machine Learning


🚀 JavaScript


📝 Protocol

ProjectVersionArticle
HTTP1.1Overview of HTTP Basics
HTTP2[RFC 7540] Hypertext Transfer Protocol Version 2 (HTTP/2)
Unveiling HTTP/2: How HTTP/2 Establishes Connections
HTTP Frames and Stream Multiplexing in HTTP/2
Frame Definitions in HTTP/2
HTTP Semantics in HTTP/2
Things to Note in HTTP/2
Common Questions in HTTP/2
[RFC 7541] HPACK: Header Compression for HTTP/2
A Detailed Look at the HTTP/2 Header Compression Algorithm — HPACK
Practical Examples of HTTP/2 HPACK
[RFC 7301] TLS Application-Layer Protocol Negotiation Extension
WebSocketVersion 13WebSocket for Full-Duplex Communication
Protocol-buffersproto3Protobuf: An Efficient Data Compression and Encoding Format
Protobuf: An Efficient Data Serialization/Deserialization Format
FlatBuffers1.9.0FlatBuffers Explained: Schema
FlatBuffers Explained: Encode
FlatBuffers Explained: FlexBuffers
TCPOverview of TCP/IP Basics
Advance_TCP
TLSCryptography
Overview of Cryptography
A Tour of Symmetric Encryption Algorithms
A Tour of Public-Key Cryptography Algorithms
What Is a Message “Fingerprint”?
What Is a Message Authentication Code?
Ubiquitous Digital Signatures
Everywhere You Look: Public-Key Certificates
The Essence of Secrets: Keys
The Root of Unpredictability—Random Numbers
TLSTLS 1.3
How to Deploy TLS 1.3?
[RFC 6520] TLS & DTLS Heartbeat Extension
[RFC 8446] The Transport Layer Security (TLS) Protocol Version 1.3
TLS 1.3 Introduction
TLS 1.3 Handshake Protocol
TLS 1.3 Record Protocol
TLS 1.3 Alert Protocol
TLS 1.3 Cryptographic Computations
TLS 1.3 0-RTT and Anti-Replay
TLS 1.3 Compliance Requirements
TLS 1.3 Implementation Notes
TLS 1.3 Backward Compatibility
TLS 1.3 Overview of Security Properties
HTTPSTLS 1.2/TLS 1.3HTTPS: Revisiting the Basics (1) — Introduction
HTTPS: Revisiting the Basics (2) — The TLS Record Layer Protocol
HTTPS: Revisiting the Basics (3) — An Intuitive Look at the TLS Handshake Process (Part 1)
HTTPS: Revisiting the Basics (4) — An Intuitive Look at the TLS Handshake Process (Part 2)
HTTPS: Revisiting the Basics (5) — Key Calculation in TLS
HTTPS: Revisiting the Basics (6) — Extensions in TLS
QUICv44How to Deploy QUIC?
                                                            

❄️ As Time Goes By

❗️ Errata

  • If you find any issues in the article, feel free to submit a PR or issue. Expert feedback and guidance are very welcome 🙏🙏🙏

♥️ Thanks

Thanks for the Star!

Star History Chart

🌈 WeChat Official Account

©️ Reposting

Creative Commons License
This work by halfrost is licensed under a Creative Commons Attribution 4.0 International License.

algorithms
blog
cryptography
go
golang
http2
inference-engine
ios
javascript
llm
machine-learning
network-protocols
objective-c
protobuf
source-code-analysis
swift
system-design
technical-writing
tls
vllm

Project health

Latest release

3.1.8 · Jul 18, 2024

Releases this year

0

Significant stargazers

(top 24 of 35)

Trim21

243 followers · starred Feb 2025

Kaixi Hou

113 followers · starred Jul 2019

mwish

618 followers · starred Feb 2025

magic-akari

795 followers · starred Jun 2018