domainaware/parsedmarc

A Python package and CLI for parsing aggregate and forensic DMARC reports

Python

1,306

942 commits

updated Oct 12, 2026

See the code

README

parsedmarc

Build
Status Code
Coverage PyPI
Package PyPI - Downloads

A screenshot of DMARC summary charts in Kibana

parsedmarc is a Python module and CLI utility for parsing DMARC reports. When used with Elasticsearch and Kibana (or Splunk), or with OpenSearch and Grafana, it works as a self-hosted open-source alternative to commercial DMARC report processing services such as Agari Brand Protection, Dmarcian, OnDMARC, ProofPoint Email Fraud Defense, and Valimail.

[!NOTE] Domain-based Message Authentication, Reporting, and Conformance (DMARC) is an email authentication protocol.

Sponsors

This project is maintained by one developer. Please consider sponsoring my work if you or your organization benefit from it.

Features

  • Parses aggregate/rua DMARC reports: the legacy draft and 1.0 schemas (RFC 7489) and the new RFC 9990 schema for the final DMARC standard (RFC 9989)
  • Parses failure/ruf DMARC reports (RFC 6591 and RFC 9991; formerly called forensic reports)
  • Parses reports from SMTP TLS Reporting (TLS-RPT, RFC 8460)
  • Can parse reports from an inbox over IMAP, Microsoft Graph, or Gmail API
  • Transparently handles gzip or zip compressed reports
  • Consistent data structures
  • Simple JSON and/or CSV output
  • Optionally email the results
  • Optionally send the results to Elasticsearch, OpenSearch, Splunk, or PostgreSQL, for use with premade dashboards
  • Optionally send the results to Apache Kafka, Amazon S3, Azure Log Analytics (Microsoft Sentinel), a Graylog (GELF) endpoint, a syslog server, or an HTTP webhook

Python Compatibility

This project supports the following Python versions, which are either actively maintained or are the default versions for RHEL or Debian.

VersionSupportedReason
< 3.6❌End of Life (EOL)
3.6❌Used in RHEL 8, but not supported by project dependencies
3.7❌End of Life (EOL)
3.8❌End of Life (EOL)
3.9❌Used in Debian 11 and RHEL 9, but not supported by project dependencies
3.10✅Actively maintained
3.11✅Actively maintained; supported until June 2028 (Debian 12)
3.12✅Actively maintained; supported until May 2035 (RHEL 10)
3.13✅Actively maintained; supported until June 2030 (Debian 13)
3.14✅Supported (requires imapclient>=3.1.0)
cli
dkim
dmarc
dmarc-parser
dmarc-reports
elasticsearch
email-authentication
email-security
opensearch
python
smtp-tls-reporting
spf
splunk

domainaware/parsedmarc

A Python package and CLI for parsing aggregate and forensic DMARC reports

Python

1,306

942 commits

updated Oct 12, 2026

See the code

README

parsedmarc

Build
Status Code
Coverage PyPI
Package PyPI - Downloads

A screenshot of DMARC summary charts in Kibana

parsedmarc is a Python module and CLI utility for parsing DMARC reports. When used with Elasticsearch and Kibana (or Splunk), or with OpenSearch and Grafana, it works as a self-hosted open-source alternative to commercial DMARC report processing services such as Agari Brand Protection, Dmarcian, OnDMARC, ProofPoint Email Fraud Defense, and Valimail.

[!NOTE] Domain-based Message Authentication, Reporting, and Conformance (DMARC) is an email authentication protocol.

Sponsors

This project is maintained by one developer. Please consider sponsoring my work if you or your organization benefit from it.

Features

  • Parses aggregate/rua DMARC reports: the legacy draft and 1.0 schemas (RFC 7489) and the new RFC 9990 schema for the final DMARC standard (RFC 9989)
  • Parses failure/ruf DMARC reports (RFC 6591 and RFC 9991; formerly called forensic reports)
  • Parses reports from SMTP TLS Reporting (TLS-RPT, RFC 8460)
  • Can parse reports from an inbox over IMAP, Microsoft Graph, or Gmail API
  • Transparently handles gzip or zip compressed reports
  • Consistent data structures
  • Simple JSON and/or CSV output
  • Optionally email the results
  • Optionally send the results to Elasticsearch, OpenSearch, Splunk, or PostgreSQL, for use with premade dashboards
  • Optionally send the results to Apache Kafka, Amazon S3, Azure Log Analytics (Microsoft Sentinel), a Graylog (GELF) endpoint, a syslog server, or an HTTP webhook

Python Compatibility

This project supports the following Python versions, which are either actively maintained or are the default versions for RHEL or Debian.

VersionSupportedReason
< 3.6❌End of Life (EOL)
3.6❌Used in RHEL 8, but not supported by project dependencies
3.7❌End of Life (EOL)
3.8❌End of Life (EOL)
3.9❌Used in Debian 11 and RHEL 9, but not supported by project dependencies
3.10✅Actively maintained
3.11✅Actively maintained; supported until June 2028 (Debian 12)
3.12✅Actively maintained; supported until May 2035 (RHEL 10)
3.13✅Actively maintained; supported until June 2030 (Debian 13)
3.14✅Supported (requires imapclient>=3.1.0)
cli
dkim
dmarc
dmarc-parser
dmarc-reports
elasticsearch
email-authentication
email-security
opensearch
python
smtp-tls-reporting
spf
splunk

Project health

Overall

5.7/10

Maintained

10/10

Code review

0/10
OpenSSF Scorecard

Latest release

11.0.3 · Sep 24, 2026

Releases this year

58

Significant stargazers

Marc Philipp

642 followers · starred Jan 2026

Sean McBride

34 followers · starred Jan 2024

Sergey B Kirpichev

80 followers · starred Dec 2019

Teodor Tanasoaia

142 followers · starred Sep 2019